const regex = /^(?<path>(\/\w+){4}).*(?<filename>\/\w+\.\w+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<path>(\\\/\\w+){4}).*(?<filename>\\\/\\w+\\.\\w+$)', 'gm')
const str = `/db2audit/fs01/db2inst1/extract/abc123/file.del`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}