$re = '/^(?<path>(\/\w+){4}).*(?<filename>\/\w+\.\w+$)/m';
$str = '/db2audit/fs01/db2inst1/extract/abc123/file.del';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);