import re
regex = re.compile(r"^(?<path>(\/\w+){4}).*(?<filename>\/\w+\.\w+$)", flags=re.MULTILINE)
test_str = "/db2audit/fs01/db2inst1/extract/abc123/file.del"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")