// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<path>(\/\w+){4}).*(?<filename>\/\w+\.\w+$)").unwrap();
let string = "/db2audit/fs01/db2inst1/extract/abc123/file.del";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}