using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^\K.*+\R?){6}";
string substitution = @"Explanation\n$0";
string input = @"Question text
A. Answer Option
B. Answer Option
C. Answer Option
D. Answer Option
Explanation text
Question text
E. Answer Option
F. Answer Option
G. Answer Option
H. Answer Option
Explanation text
Question text
I. Answer Option
J. Answer Option
K. Answer Option
L. Answer Option
Explanation text
Question text
M. Answer Option";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}