# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:^\K.*+\R?){6}"
test_str = ("Question text\n"
"A. Answer Option\n"
"B. Answer Option\n"
"C. Answer Option\n"
"D. Answer Option\n"
"Explanation text\n"
"Question text\n"
"E. Answer Option\n"
"F. Answer Option\n"
"G. Answer Option\n"
"H. Answer Option\n"
"Explanation text\n"
"Question text\n"
"I. Answer Option\n"
"J. Answer Option\n"
"K. Answer Option\n"
"L. Answer Option\n"
"Explanation text\n"
"Question text\n"
"M. Answer Option")
subst = "Explanation\\n$0"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.