$re = '/(?:^\K.*+\R?){6}/m';
$str = 'Question text
A. Answer Option
B. Answer Option
C. Answer Option
D. Answer Option
Explanation text
Question text
E. Answer Option
F. Answer Option
G. Answer Option
H. Answer Option
Explanation text
Question text
I. Answer Option
J. Answer Option
K. Answer Option
L. Answer Option
Explanation text
Question text
M. Answer Option';
$subst = "Explanation\n$0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;