using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^url\(.+\)$";
string input = @"url(https://picsum.photos/99/148?grayscale)
url('https://picsum.photos/99/148?grayscale')
url(""https://picsum.photos/99/148?grayscale"")";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}