$re = '/^url\(.+\)$/m';
$str = 'url(https://picsum.photos/99/148?grayscale)
url(\'https://picsum.photos/99/148?grayscale\')
url("https://picsum.photos/99/148?grayscale")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);