re = /^url\(.+\)$/m
str = 'url(https://picsum.photos/99/148?grayscale)
url(\'https://picsum.photos/99/148?grayscale\')
url("https://picsum.photos/99/148?grayscale")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end