import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)[\\\\n\\\\t]+([\\W\\w]+[^\\\\n\\\\t\"$])";
final String string = "\"\\n\\t\\t\\t\\t\\t\\t<span class=\\\"crowns-container\\\">\\n\\t\\t\\t\\t\\t\\t\\t<span class=\\\"user-crowns\\\">\\n\\t\\t\\t\\t\\t\\t\\t\\t<!---->\\n\\t\\t\\t\\t\\t\\t\\t\\t<!---->\\n\\t\\t\\t\\t\\t\\t\\t\\t<!---->\\n\\t\\t\\t\\t\\t\\t\\t\\t<!----><span ng-if=\\\"!user.globalSpenderRank\\\">\\n\\t\\t\\t\\t\\t\\t\\t\\t\\t<i class=\\\"ynicon ynicon-level\\\"></i>\\n\\t\\t\\t\\t\\t\\t\\t\\t</span><!---->\\n\\t\\t\\t\\t\\t\\t\\t</span>\\n\\t\\t\\t\\t\\t\\t</span>\\n\\t\\t\\t\\t\\t\\t14\\n\\t\\t\\t\\t\\t\\t_You Won\\n\\t\\t\\t\\t\\t\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}