// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(\d+)[\\n\\t]+([\W\w]+[^\\n\\t"$])"#).unwrap();
let string = "\"\\n\\t\\t\\t\\t\\t\\t<span class=\\\"crowns-container\\\">\\n\\t\\t\\t\\t\\t\\t\\t<span class=\\\"user-crowns\\\">\\n\\t\\t\\t\\t\\t\\t\\t\\t<!---->\\n\\t\\t\\t\\t\\t\\t\\t\\t<!---->\\n\\t\\t\\t\\t\\t\\t\\t\\t<!---->\\n\\t\\t\\t\\t\\t\\t\\t\\t<!----><span ng-if=\\\"!user.globalSpenderRank\\\">\\n\\t\\t\\t\\t\\t\\t\\t\\t\\t<i class=\\\"ynicon ynicon-level\\\"></i>\\n\\t\\t\\t\\t\\t\\t\\t\\t</span><!---->\\n\\t\\t\\t\\t\\t\\t\\t</span>\\n\\t\\t\\t\\t\\t\\t</span>\\n\\t\\t\\t\\t\\t\\t14\\n\\t\\t\\t\\t\\t\\t_You Won\\n\\t\\t\\t\\t\\t\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}