const regex = /(\d+)[\\n\\t]+([\W\w]+[^\\n\\t"$])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)[\\\\n\\\\t]+([\\W\\w]+[^\\\\n\\\\t"$])', 'g')
const str = `"\\n\\t\\t\\t\\t\\t\\t<span class=\\"crowns-container\\">\\n\\t\\t\\t\\t\\t\\t\\t<span class=\\"user-crowns\\">\\n\\t\\t\\t\\t\\t\\t\\t\\t<!---->\\n\\t\\t\\t\\t\\t\\t\\t\\t<!---->\\n\\t\\t\\t\\t\\t\\t\\t\\t<!---->\\n\\t\\t\\t\\t\\t\\t\\t\\t<!----><span ng-if=\\"!user.globalSpenderRank\\">\\n\\t\\t\\t\\t\\t\\t\\t\\t\\t<i class=\\"ynicon ynicon-level\\"></i>\\n\\t\\t\\t\\t\\t\\t\\t\\t</span><!---->\\n\\t\\t\\t\\t\\t\\t\\t</span>\\n\\t\\t\\t\\t\\t\\t</span>\\n\\t\\t\\t\\t\\t\\t14\\n\\t\\t\\t\\t\\t\\t_You Won\\n\\t\\t\\t\\t\\t"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}