# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,(?!\d)/\n/gm;t' <<< "aaa,bbb,$33,222,ccc,$22,000"