const regex = /,(?!\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',(?!\\d)', 'gm')
const str = `aaa,bbb,\$33,222,ccc,\$22,000`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);