use strict;
my $str = 'aaa,bbb,$33,222,ccc,$22,000';
my $regex = qr/,(?!\d)/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";