#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^([a-z0-9]*:|.{0})\/\/.*$"
Local $sString = "http://www.stackoverflow.com" & @CRLF & _
"about.html" & @CRLF & _
"tutorial1/" & @CRLF & _
"tutorial1/2.html" & @CRLF & _
"/" & @CRLF & _
"/experts/ " & @CRLF & _
"https://google.com" & @CRLF & _
"../ " & @CRLF & _
"../experts/ " & @CRLF & _
"../../../ " & @CRLF & _
"./ " & @CRLF & _
"./about.html" & @CRLF & _
"https://regex101.com" & @CRLF & _
"//something" & @CRLF & _
"/something" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")