using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-z0-9]*:|.{0})\/\/.*$";
string input = @"http://www.stackoverflow.com
about.html
tutorial1/
tutorial1/2.html
/
/experts/
https://google.com
../
../experts/
../../../
./
./about.html
https://regex101.com
//something
/something
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}