const regex = /^([a-z0-9]*:|.{0})\/\/.*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-z0-9]*:|.{0})\\\/\\\/.*$', 'gmi')
const str = `http://www.stackoverflow.com
about.html
tutorial1/
tutorial1/2.html
/
/experts/
https://google.com
../
../experts/
../../../
./
./about.html
https://regex101.com
//something
/something
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}