re = /^([a-z0-9]*:|.{0})\/\/.*$/mi
str = 'http://www.stackoverflow.com
about.html
tutorial1/
tutorial1/2.html
/
/experts/
https://google.com
../
../experts/
../../../
./
./about.html
https://regex101.com
//something
/something
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end