import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{5}\\s?\\d{5})?\\s?(parcel\\s?locker)\\s?(\\d{5}\\s?\\d{5})?";
final String string = "Parcel Locker 10080 88673\n"
+ "parcel locker 10080 88673\n\n"
+ "Parcel Locker 1008088673\n"
+ "parcel locker 1008088673\n\n"
+ "ParcelLocker1008088673\n"
+ "parcellocker1008088673\n"
+ "parcel locker1008088673\n"
+ "parcel locker 1008088673\n"
+ "parcel locker 10080 88673\n\n"
+ "10080 88673 Parcel Locker\n"
+ "10080 88673 parcel locker\n\n"
+ "1008088673ParcelLocker\n"
+ "1008088673parcellocker\n"
+ "hejsan parcel locker thug\n"
+ "Parcel street 1234567890\n"
+ "1234567890 Parcel street \n"
+ "Locker srteet 1234567890";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}