re = /(\d{5}\s?\d{5})?\s?(parcel\s?locker)\s?(\d{5}\s?\d{5})?/i
str = 'Parcel Locker 10080 88673
parcel locker 10080 88673
Parcel Locker 1008088673
parcel locker 1008088673
ParcelLocker1008088673
parcellocker1008088673
parcel locker1008088673
parcel locker 1008088673
parcel locker 10080 88673
10080 88673 Parcel Locker
10080 88673 parcel locker
1008088673ParcelLocker
1008088673parcellocker
hejsan parcel locker thug
Parcel street 1234567890
1234567890 Parcel street
Locker srteet 1234567890'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end