re = /(\d+)(?!.*\d)/
str = '<p style="font-family:Arial, Helvetica, sans-serif; font-size:18px;"> <strong> This is the information you need 5 times you can see.</strong></p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end