#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(COM-)(ALM\d{1,2}_)(BIT$|BIT\D.*|(?!BIT)\D.*)"
Local $sString = "COM-ALM2_BIT_1" & @CRLF & _
"COM-ALM2_BIT" & @CRLF & _
"COM-ALM2_AZIrgendwas_1" & @CRLF & _
"COM-ALM3_NameBIT" & @CRLF & _
"COM-ALM3_BITName" & @CRLF & _
"COM-ALM3_Name" & @CRLF & _
"COM-ALM2_BIT1" & @CRLF & _
"COM-ALM2_BIT15" & @CRLF & _
"COM-ALM11_BIT7" & @CRLF & _
"COM-ALM11_BIT11" & @CRLF & _
"OM-ALM_BIT1" & @CRLF & _
"COM-ALM_Name"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")