re = /(COM-)(ALM\d{1,2}_)(BIT$|BIT\D.*|(?!BIT)\D.*)/m
str = 'COM-ALM2_BIT_1
COM-ALM2_BIT
COM-ALM2_AZIrgendwas_1
COM-ALM3_NameBIT
COM-ALM3_BITName
COM-ALM3_Name
COM-ALM2_BIT1
COM-ALM2_BIT15
COM-ALM11_BIT7
COM-ALM11_BIT11
OM-ALM_BIT1
COM-ALM_Name'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end