using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(COM-)(ALM\d{1,2}_)(BIT$|BIT\D.*|(?!BIT)\D.*)";
string input = @"COM-ALM2_BIT_1
COM-ALM2_BIT
COM-ALM2_AZIrgendwas_1
COM-ALM3_NameBIT
COM-ALM3_BITName
COM-ALM3_Name
COM-ALM2_BIT1
COM-ALM2_BIT15
COM-ALM11_BIT7
COM-ALM11_BIT11
OM-ALM_BIT1
COM-ALM_Name";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}