import Foundation
let pattern = #"(COM-)(ALM\d{1,2}_)(BIT$|BIT\D.*|(?!BIT)\D.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
COM-ALM2_BIT_1
COM-ALM2_BIT
COM-ALM2_AZIrgendwas_1
COM-ALM3_NameBIT
COM-ALM3_BITName
COM-ALM3_Name
COM-ALM2_BIT1
COM-ALM2_BIT15
COM-ALM11_BIT7
COM-ALM11_BIT11
OM-ALM_BIT1
COM-ALM_Name
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)