# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\D*(\b\d+([,.]\d+)*\b).*$/$1/gm;t' <<< "Test 120,00 Euro yaddayadda
200 € with 18 months of blablabla
3.000,65 € something . And here s something more with 0815. And more.
1 Euro
Last item for 5.234.789,00 Euro."