// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\D*(\b\d+([,.]\d+)*\b).*$").unwrap();
let string = "Test 120,00 Euro yaddayadda
200 € with 18 months of blablabla
3.000,65 € something . And here s something more with 0815. And more.
1 Euro
Last item for 5.234.789,00 Euro.";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}