package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\D*(\b\d+([,.]\d+)*\b).*$`)
var str = `Test 120,00 Euro yaddayadda
200 € with 18 months of blablabla
3.000,65 € something . And here s something more with 0815. And more.
1 Euro
Last item for 5.234.789,00 Euro.`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}