# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\D*(\b\d+([,.]\d+)*\b).*$"
test_str = ("Test 120,00 Euro yaddayadda\n"
"200 € with 18 months of blablabla\n"
"3.000,65 € something . And here s something more with 0815. And more.\n"
"1 Euro\n"
"Last item for 5.234.789,00 Euro.")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.