#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(junior|consultant|freelance|advisor|student|intern|investor|logistics?|industr(y|ial)|construction|technolog(y|ies)|c[tfpo]o|finance|talent|human|hr|people|bras[\-\s]droit|right[\-\s]arm|partnerships?|communications?|paid|ads|seo|strategist|outsourced|temporary)\b"
Local $sString = " "Revenue Ops Manager"," & @CRLF & _
" "Growth Marketing Manager"," & @CRLF & _
" "CEO"," & @CRLF & _
" "Director of Operations"," & @CRLF & _
" "Sales Ops Analyst"," & @CRLF & _
" "VP of Sales"," & @CRLF & _
" "Marketing Operations Specialist"," & @CRLF & _
" "Lead Generation Manager"," & @CRLF & _
" "Product Ops Director"," & @CRLF & _
" "GTM Strategy Lead"," & @CRLF & _
" "Head of Growth"," & @CRLF & _
" "Chief Marketing Officer"," & @CRLF & _
" "Director of Business Development"," & @CRLF & _
" "Junior Revenue Analyst"," & @CRLF & _
" "Freelance Growth Consultant"," & @CRLF & _
" "CTO and Product Owner"," & @CRLF & _
" "Sales Development Representative"," & @CRLF & _
" "Intern Marketing Operations"," & @CRLF & _
" "Business Systems Administrator"," & @CRLF & _
" "Country Manager and COO"," & @CRLF & _
" "Chief Growth Officer"," & @CRLF & _
" "VP Marketing and Communications"," & @CRLF & _
" "Head of Business Opportunities"," & @CRLF & _
" "Revenue Operations Specialist"," & @CRLF & _
" "Product Marketing Manager""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")