import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(junior|consultant|freelance|advisor|student|intern|investor|logistics?|industr(y|ial)|construction|technolog(y|ies)|c[tfpo]o|finance|talent|human|hr|people|bras[\\-\\s]droit|right[\\-\\s]arm|partnerships?|communications?|paid|ads|seo|strategist|outsourced|temporary)\\b";
final String string = " \"Revenue Ops Manager\",\n"
+ " \"Growth Marketing Manager\",\n"
+ " \"CEO\",\n"
+ " \"Director of Operations\",\n"
+ " \"Sales Ops Analyst\",\n"
+ " \"VP of Sales\",\n"
+ " \"Marketing Operations Specialist\",\n"
+ " \"Lead Generation Manager\",\n"
+ " \"Product Ops Director\",\n"
+ " \"GTM Strategy Lead\",\n"
+ " \"Head of Growth\",\n"
+ " \"Chief Marketing Officer\",\n"
+ " \"Director of Business Development\",\n"
+ " \"Junior Revenue Analyst\",\n"
+ " \"Freelance Growth Consultant\",\n"
+ " \"CTO and Product Owner\",\n"
+ " \"Sales Development Representative\",\n"
+ " \"Intern Marketing Operations\",\n"
+ " \"Business Systems Administrator\",\n"
+ " \"Country Manager and COO\",\n"
+ " \"Chief Growth Officer\",\n"
+ " \"VP Marketing and Communications\",\n"
+ " \"Head of Business Opportunities\",\n"
+ " \"Revenue Operations Specialist\",\n"
+ " \"Product Marketing Manager\"";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}