import Foundation
let pattern = #"(junior|consultant|freelance|advisor|student|intern|investor|logistics?|industr(y|ial)|construction|technolog(y|ies)|c[tfpo]o|finance|talent|human|hr|people|bras[\-\s]droit|right[\-\s]arm|partnerships?|communications?|paid|ads|seo|strategist|outsourced|temporary)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
"Revenue Ops Manager",
"Growth Marketing Manager",
"CEO",
"Director of Operations",
"Sales Ops Analyst",
"VP of Sales",
"Marketing Operations Specialist",
"Lead Generation Manager",
"Product Ops Director",
"GTM Strategy Lead",
"Head of Growth",
"Chief Marketing Officer",
"Director of Business Development",
"Junior Revenue Analyst",
"Freelance Growth Consultant",
"CTO and Product Owner",
"Sales Development Representative",
"Intern Marketing Operations",
"Business Systems Administrator",
"Country Manager and COO",
"Chief Growth Officer",
"VP Marketing and Communications",
"Head of Business Opportunities",
"Revenue Operations Specialist",
"Product Marketing Manager"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)