#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)."
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"abcdefghijklmnopqrstuvwxyz" & @CRLF & _
"ABCDEFGHIJKLMNOPQRSTUVWXYZ" & @CRLF & _
"1234567890" & @CRLF & _
"" & @CRLF & _
"Ha HaHa" & @CRLF & _
"" & @CRLF & _
"MetaCharacters (Need to .be escaped):" & @CRLF & _
".[{(\^$|?*+" & @CRLF & _
"" & @CRLF & _
"cat" & @CRLF & _
"mat" & @CRLF & _
"bat" & @CRLF & _
"pat"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")