re = /./m
str = '
abcdefghijklmnopqrstuvwxyz
ABCDEFGHIJKLMNOPQRSTUVWXYZ
1234567890
Ha HaHa
MetaCharacters (Need to .be escaped):
.[{(\\^$|?*+
cat
mat
bat
pat'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end