package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).`)
var str = `
abcdefghijklmnopqrstuvwxyz
ABCDEFGHIJKLMNOPQRSTUVWXYZ
1234567890
Ha HaHa
MetaCharacters (Need to .be escaped):
.[{(\^$|?*+
cat
mat
bat
pat`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}