import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".";
final String string = "\n\n"
+ "abcdefghijklmnopqrstuvwxyz\n"
+ "ABCDEFGHIJKLMNOPQRSTUVWXYZ\n"
+ "1234567890\n\n"
+ "Ha HaHa\n\n"
+ "MetaCharacters (Need to .be escaped):\n"
+ ".[{(\\^$|?*+\n\n"
+ "cat\n"
+ "mat\n"
+ "bat\n"
+ "pat";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}