using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\/url\?q=|&.+)";
string input = @"/url?q=https://website.com/&sa=U&ved=2ahUKEwjNyNv9z7fdfdXHEFkFHUpsEK8QFnoECAUQAg&usg=Agggaw2opjkKEAUPzyKjTJnkzQyZ";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}