package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:\/url\?q=|&.+)`)
var str = `/url?q=https://website.com/&sa=U&ved=2ahUKEwjNyNv9z7fdfdXHEFkFHUpsEK8QFnoECAUQAg&usg=Agggaw2opjkKEAUPzyKjTJnkzQyZ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}