re = /(?:\/url\?q=|&.+)/i
str = '/url?q=https://website.com/&sa=U&ved=2ahUKEwjNyNv9z7fdfdXHEFkFHUpsEK8QFnoECAUQAg&usg=Agggaw2opjkKEAUPzyKjTJnkzQyZ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end