using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"password(?:=""?|%3D%22)[^&\""]*?(?:(?=%22)|""|$)";
string input = @"http://host?foo=bar&xml=%3C%3Fxml+id%3D%220abc987%22+password%3D%22secreT12aa5%22+binds%3D%222%22
password=""value""
http://host?password=value";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}