const regex = /password(?:="?|%3D%22)[^&\"]*?(?:(?=%22)|"|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('password(?:="?|%3D%22)[^&\\"]*?(?:(?=%22)|"|$)', 'g')
const str = `http://host?foo=bar&xml=%3C%3Fxml+id%3D%220abc987%22+password%3D%22secreT12aa5%22+binds%3D%222%22
password="value"
http://host?password=value`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}