$re = '/password(?:="?|%3D%22)[^&\"]*?(?:(?=%22)|"|$)/';
$str = 'http://host?foo=bar&xml=%3C%3Fxml+id%3D%220abc987%22+password%3D%22secreT12aa5%22+binds%3D%222%22
password="value"
http://host?password=value';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);