import re
regex = re.compile(r"password(?:=\"?|%3D%22)[^&\"]*?(?:(?=%22)|\"|$)")
test_str = ("http://host?foo=bar&xml=%3C%3Fxml+id%3D%220abc987%22+password%3D%22secreT12aa5%22+binds%3D%222%22\n"
"password=\"value\"\n"
"http://host?password=value")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")