#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+([-+.']\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*$"
Local $sString = "vinamra@gmail.com" & @CRLF & _
"vinm@fmmao.com" & @CRLF & _
"vin @ . com " & @CRLF & _
"vdd@us.com.com" & @CRLF & _
"sh sha @cc.com" & @CRLF & _
"vin@dnsldfnsdlfsnflsnslfnd.com" & @CRLF & _
"ddd@11.com" & @CRLF & _
"sdf@ff.com" & @CRLF & _
"as@com" & @CRLF & _
"john @gmail.com" & @CRLF & _
"Akasdfgnqwefujqfj^1234!1k@gmail.com" & @CRLF & _
"T1hisi4snot5anem6ail@mcd.com" & @CRLF & _
"John.Smith@mcd.com" & @CRLF & _
"Joe.Smith@cmd.com" & @CRLF & _
"test" & @CRLF & _
"" & @CRLF & _
"@ ." & @CRLF & _
"" & @CRLF & _
"john @bkla.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")