import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+([-+.']\\w+)*@\\w+([-.]\\w+)*\\.\\w+([-.]\\w+)*$";
final String string = "vinamra@gmail.com\n"
+ "vinm@fmmao.com\n"
+ "vin @ . com \n"
+ "vdd@us.com.com\n"
+ "sh sha @cc.com\n"
+ "vin@dnsldfnsdlfsnflsnslfnd.com\n"
+ "ddd@11.com\n"
+ "sdf@ff.com\n"
+ "as@com\n"
+ "john @gmail.com\n"
+ "Akasdfgnqwefujqfj^1234!1k@gmail.com\n"
+ "T1hisi4snot5anem6ail@mcd.com\n"
+ "John.Smith@mcd.com\n"
+ "Joe.Smith@cmd.com\n"
+ "test\n\n"
+ "@ .\n\n"
+ "john @bkla.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}