// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\w+([-+.']\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*$").unwrap();
let string = "vinamra@gmail.com
vinm@fmmao.com
vin @ . com
vdd@us.com.com
sh sha @cc.com
vin@dnsldfnsdlfsnflsnslfnd.com
ddd@11.com
sdf@ff.com
as@com
john @gmail.com
Akasdfgnqwefujqfj^1234!1k@gmail.com
T1hisi4snot5anem6ail@mcd.com
John.Smith@mcd.com
Joe.Smith@cmd.com
test
@ .
john @bkla.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}