#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*([^\nw].{5}|.[^\no].{4}|.{2}[^\nr].{3}|.{3}[^\nl].{2}|.{4}[^\nd].|.{5}[^\n.])|.{0,5})$"
Local $sString = "1" & @CRLF & _
"12" & @CRLF & _
"123" & @CRLF & _
"1234" & @CRLF & _
"12345" & @CRLF & _
"123456" & @CRLF & _
"Hello, world." & @CRLF & _
"Hello, world" & @CRLF & _
"Hello, world. " & @CRLF & _
" ^ Spaces added ^"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")