package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*([^\nw].{5}|.[^\no].{4}|.{2}[^\nr].{3}|.{3}[^\nl].{2}|.{4}[^\nd].|.{5}[^\n.])|.{0,5})$`)
var str = `1
12
123
1234
12345
123456
Hello, world.
Hello, world
Hello, world.
^ Spaces added ^`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}